Cela fait longtemps que j'ai installé Joomla_4.0 (dès sa version béta donc 14-02-2019).

J'appends que Regular Labs a mis à jour les plugins que j'utilise;

  • Articles anywhere (plugin plus compatible depuis joomla_4.0)
  • Modules anywhere
  • Cache Cleaner
  • Modules Anywhere
  • Le seul plugin qui n'a pas de mise à jour (Tabs) est disponible en version de développement
    https://regularlabs.com/development-releases

Je tente la mise à jour : j'ai l'erreur suivante

 

 Argument 2 passed to RegularLabsInstallerScriptHelper::preflight() must be an instance of JAdapterInstance, instance of Joomla\CMS\Installer\Adapter\LibraryAdapter given
 

 

En lisant sur le forum de Regular labs ils conseillent de désinstaller physiquement les plugins avant de les mettre à jour.
Cela signifie supprimer les répertoires associés:

  • administrator\components\com_regularlabsmanager
  • libraries\regularlabs
  • plugins\system\articleanywhere
  • plugins\system\componentsanywhere
  • plugins\system\modulesanywhere
  • plugins\system\tabs
  • plugins\system\sliders

Je désactive aussi les plugins panneaux déroulants et tab
et je lance la mise à jour => succès

Pour les tabs Regular labs a fournir un workarround en attendant la mse à jour
https://regularlabs.com/development-releases


Tabs & Accordions conteint l'adaptation pour les appels tabs


le plugin temporaire n'accepte pas les alias ni les attributs couleurs
{tab Mentions Légales|green|alias:mentions-legales}
=> à convertir en
{tab Mentions Légales}